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1 Introduction: Integrating a
Processor Expert driver
into a project

There are many reasons for adding a single Processor Expert
(PEx) driver into an application.
» Lack of time to develop drivers for the product.
* Complications involved in the module which requires
drivers
* Future plans to integrate an operating system into the
application

Whatever the reason for adding drivers to a project,
integrating PEXx drivers into an application, that is not a
dedicated PEx project, can be a non-trivial task.

This application note discusses the process and techniques for
integrating a single Processor Expert driver into a “baremetal”
project. An example of such integration is also included for
reference. The example application was built and tested using
IAR 6.50.6 Embedded Workbench and targets TWR-
K60NS512 tower board. The PEx driver files were created
using Processor Expert Driver Suite v10.0.2.
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2 Processor Expert basics

Before discussing how to integrate a PEx driver into an application, the users must first have a basic understanding of
Processor Expert and the files it generates. Processor Expert is a development system to create, configure, optimize, migrate,
and deliver software components which can generate source code for Freescale silicon. Users interact with a graphical
interface to configure the desired components for their project. Processor Expert is available as part of the CodeWarrior tool
suite or as an Eclipse-based plug-in feature for installation into an independent Eclipse environment.

With any Processor Expert project, there are essentially two different types of components to will deal with: CPU
components and embedded components. These two components are examined in the following subsections.

2.1 CPU components

CPU components specify the device which the project targets such as MKL25Z128VLK4, MK60N512VMD100, and
MK40X256VMDI100. There can be only one active CPU component in a project. Within the CPU component, the user
configures the core oscillator, internal oscillators, interrupt settings, watchdog settings, power mode settings, and other global
settings that the project may require. MCU modules associated with the CPU component are as follows:

* Multipurpose Clock Generator (MCG)

* System Integration Module (SIM)

* Power Management Controller (PMC)

¢ Oscillator (OSC)

* Low-Leakage Wake-Up Unit (LLWU)

* Watchdog (WDOG) (if applicable)

NOTE
This is not an all inclusive list. Some pins or other peripherals may be configured through
the code generated by the CPU component.

2.2 Embedded components

Embedded Components comprise all of the MCU modules that are not configured by the CPU component. In general, only
the peripheral modules are included in this category. There are three different types of embedded components:

* High/low level components
¢ Logical Device Driver (LDD) components
* Peripheral Initialization components

This application note examines the integration of the LDD component into a project as this component is more powerful than
the peripheral initialization component and the building block of the high/low level components.

3 Processor Expert files

As discussed in Processor Expert basics, Processor Expert generates the files necessary to create an application. Therefore, it
is necessary to understand the files generated and their specific function, before knowing which files are necessary or
unnecessary to include in a project. This table presents the contents of each of the files generated by Processor Expert.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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General procedure for integrating a Processor Expert driver into your project

Table 1. Processor Expert file descriptions

File Contents

CPU.c Contains standard functions that configure the CPU such as
memory, MCG, SIM

CPU.h Contains definitions, structure declarations, and function
declarations required by CPU.c.

I0_Map.h Device-specific header file that defines registers and bitmasks

PE_Const.h Defines masks for causes of reset and low-voltage detect

PE_Error.h Defines PE-specific error masks

PE_LDD.c Contains LDD-specific structure declarations and general
functions that LDDs may require.

PE_Types.h Defines standard types and macros common to LDDs

Vectors.c Defines the reset and interrupt vectors

* PDD.c "Physical Device Driver" that contains module-specific
definitions required by the LDDs

4 General procedure for integrating a Processor Expert

driver into your project

The following steps provide a general procedure for integrating a PEx Logical Device Driver into your project. It is important
to remember that every driver may not integrate exactly the same way into every project.

NOTE

The following instructions assume the user has a basic knowledge of PEx. A more
detailed example is included for user convenience and for those that are new to Processor

Expert.

1. Create a Processor Expert project.

* Be sure to select the appropriate device when creating the project.
 Itis recommended to save the PEx project in the same folder as the tool chain project (or the folder where you
plan to save the tool chain project) with a descriptive name.

2. Configure the PEx project.

* Add the desired component to the project and configure it as desired.
* As a general rule, the clock configurations should be set up exactly as they would be in your application. This is
required only if the driver being created depends on the clock configurations of the part, such as a timer or a

communications module.

3. Generate the code.

* When generating the code, do not use the automated scripts. These scripts are useful when creating a full
Processor Expert project, but can make things complicated when trying to use just one driver.

4. Add the generated code to the bare-metal project.

* The following files will be required when integrating the newly created PEx driver:

¢ Events.c

¢ Events.h

e PE_LDD.c
PE_LDD.h
* PE_Types.h

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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* <Component Name>.c
* <Component Name>.h
» The associated Physical Device Driver (PDD) header file will also need to be included in the project. For
example, if an ADC LDD was added to the project, the compiler tool that you using must be able to locate the
file ADC_PDD.h.

NOTE
The PDD files are with your PEx build, located at <PEx Root Dir>\eclipse
\ProcessorExpert\lib\Kinetis\pdd\inc.

5. Modify the driver files that have been added to the project.

¢ In general, include files should be included through one common include file as much as possible. This avoids
duplicated definitions of variables and constants.

* Each driver file may be slightly different. So the required include files may change slightly for each driver.

* None of the files added to the project will need to include Cpu.h, PE_Types.h, IO_Map.h, or PE_Const.h. These
files are either not needed or the information they contain should already be included in the project.

* All the functions in PE_LDD.c should all be removed except for the LDD_DeviceData definition (the driver
functions will need this definition).

* It may be necessary to add some definitions from some of the aforementioned files to the common files. These
may differ from driver to driver.

5 Example driver integration

Now consider the example of adding an [2C LDD to an example from the Kinetis K60 sample code (KINETIS512_SC.zip
package). For this example, a custom project has been created (named PEx_Drv_Int_Training) which is based on the Hello
World project from the KINETIS512_SC code package. This project already includes code specific to using the [2C_LDD
for convenience.

1. Create the Processor Expert project.

a. Choose Start > All Programs > Freescale Processor Expert > PExDrv v10.2 >eclipse, to open Processor Expert
10.2.

b. Select an empty folder for your workspace.
c. Choose File > New > Processor Expert Project.

C/C++ - Processor Expert Software
Edit Socurce Refactor Mavigate Search Run Project  Processor Expert Window  Help

Mew Alt+Shift+M » | ‘-:} Embedded Component Project
Open File... % Processor Expert Project
Close Ctrl+ W % Processor Expert MQX-Lite Project
Close All Ctrl+Shift+W Makefile Project with Existing Code
Save s B et Brae
Sove A c| ©CProject

[t Mleminr+

Figure 1. New Processor Expert project creation
d. Deselect the "Use default location" option and set the Location and Project name as shown in the following figure
(your PEx project should be stored in ..\build\iar\PEx_Drv_Int_Training\PE):

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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I =

Mew Processor Expert Project | = @

Create a Processor Expert Project

Choose the location for the new project

Project name:  PEx_Drv_Int_Training

[] Use default location
Location:  CAPEx_Drv_Int_Start\build\iar\PEx_Dre_Int_Training'PE Browse...

Choose file system:

@ < Back Next > e

Figure 2. Storing Processor Expert project
e. Select the appropriate device in the PE device selection dialog, as shown in the following figure.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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.- =

Mew Processor Expert Project | = @

Devices

Select the derivative you would like to use

Processor to be used:

type filter text

-~ ColdFire
a Kinetis
> MKL0
= MK20
» ME30
- MEAD
> MKSD
4 MEBD
4 MEBOD (100MHz)
MEBODMN256 50010
MEBIDM2 560010
MEBODMN512E00d0
MEBODMN51 230010
MEBODH256 5000
MEBODX 2560010
» MKBOF (L20MHz, 150MHz)
- MKEBLF (L20MHz, 150MHz)

> MKT0
> Kinetis L
Creates project for MEBIDM512:0040 derivative -
@ | <Back | Mea> || Ensh || Cancel

Figure 3. PEx device selection dialog
f. In the PE tool selection dialog:
 For "Start with perspective designed for" select the "Use current perspective" option.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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.-

Mew Processor Expert Project

Rapid Application Development
Processor Expert

Start with perspective designed for
(") Hardware configuration (pin muxing and device initialization)

(@ Use current perspective

Initialize all peripherals

Use current perspective and show Processor Expert views.

(=[O =]

@ | <Back || Nea> || Finish

J

Cancel

Figure 4. PEx tool selection dialog

g. Select IAR ARM C Compiler for the Target compiler in the PE tool chain selection dialog, as shown in the

following figure.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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.-

E Mew Processor Expert Project

Processor Expert Target Compiler
Target compiler

=)

Target compiler

CodeWarrior ARM C Cornpiler

Keil ARM C/C++ Compiler

GMU C Compiler
IAR ARM C Compiler

@ ot

| Finish

] ’ Cancel

Figure 5. Tool chain selection dialog

h. Click Finish.

2. Configure PEx Project to the same clock configurations the application will use. The desired clock configuration for
this application is: core frequency of 96 MHz, bus frequency of 48 MHz, and flash clock frequency of 24 MHz using a

50 MHz external clock.
a. Select the Expert visibility tab in PEx.

‘essor Expert  Window Help

@B O U @S P

-Cpu 22

E| (1] 2 Tl T
Basic Advanced| |Expert =
=

wents | Build options Resuurceq

Figure 6. Setting Expert visibility in PEx

b. In the Component Inspector - Cpu window, select the Properties tab and enable the system oscillator and its

settings.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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Example driver integration

4y Component Inspector - Cpu &7 e

Prupertie;\MMethodﬂ Events'l Build opticns Resourceq

Mame Value
Component narme Cpu
CPU type MEBODNS12VLOL0

4 Clock settings
4 Internal oscillator
Slow internal reference clock [kHz] 32,768

> Initialize slow trim value no
Fast internal reference clock [MHz] 4.0
» Initialize fast trim value no
- RTC oscillator Disabled
4 System oscillator 0 Enabled
4 Clock source External reference clock
4 Clock input pin
Pin name EXTALD/PTALE/FTMO_FLTZ/FTM_...
Pin signal
Clock frequency [MHz] 50.0

Figure 7. CPU component oscillator configuration section
c. For MCG settings, select PEE mode as the MCG mode, and configure the PLL settings as shown in this figure.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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% Component Inspector - Cpu 2 N

Pru:uperties.' _Methods | Events | Build options | Remurces.

Mame Value
- Initialize fast trim value ne
> RTC oscillator Disabled
4 System oscillator 0 Enabled
a Clock source External reference clock
4 Clock input pin
Pin name EXTALO/PTALE/FTMO_FLT2/FTM_...
Pin signal
Clock frequency [MHz] 50.0
4 Clock source settings 1

4 Clock source setting 0
» Internal reference clock
» External reference clock

4 MCG settings
MCG mode PEE
MCG output clock PLL clock
MCG cutput [MHz] 96.0

MCG external ref. clock source Systern oscillator 0
MG external ref. clock [MHz] 50.0

Clock monitor Dizabled

> FLL settings

4 PLL 0 settings
PLL module Enabled
PLL rnodule in Stop Dizabled
PLL output [MHz] 96.0
Reference clock divider Auto select
PLL reference clock [MHz] 2.0
Multiplication factor Auto select
Loss of lock interrupt Dizabled

Figure 8. MCG settings in CPU component oscillator configuration section
d. Configure the System clocks in the clock configuration as shown in this figure.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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% Compenent Inspector - Cpu X

P'ru:upertie.s' \ Methcrds. Events.. Build crpticrns. Resources

Marne Yalue
Compenent name Cpu
CPU type MEBODMS12YLOL0
- Clock settings
Initializaticn pricrity minimal pricrity
Watchdog disable yes

» Internal peripherals
- CPU interrupts/resets

- External Bus Disabled
> Low power mode settings
4 Clock configurations 1
4 Clock configuration 0
> Very low power mode Disabled
4 Clock source setting configuration
MCG mode PEE
MCG output [MHz] 9a.0
MCGIRCLE clock [MHz] 0.032768
OSCERCLE clock [MHz] 50
ERCLE3ZK. clock [kHz] 0
MCGFFCLE [kHz] 244140625
a4 System clocks
Core clock prescaler Auto select
Core clock 96.0
Bus clock prescaler Auto select
Bus clock 48.0
External clock prescaler Auto select
External bus clock 43.0
Flash clock prescaler Auto select
Flash clock 240
a4 PLL/FLL clock selection PLL clock
Clock frequency [MHz] 96.0

Figure 9. CPU component system clocks configuration
3. Add the I2C_LDD component to the project.
a. Right-click the I2C_LDD component and select Add to Project.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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e v o e ® - o

o= Outline (@3 Make Target (El Task Lis

Categoriesf| Alphabetical Assistanﬂ Processorﬂ

Component Co...
& ADC High
A% ADC_LDD Logi...
12| AnalogCoi Logi...
@ Asynchros High
@8 Bareboard Oper...
@ citlo High
8 Bitl0_LDD Logi..
@ BitsIo  High
8 BitsI0_LDL Logi...
B CAN_LDD Logi..
i CMT_LDD Logi...
Consolel0 High =
& CRC_LDD Logi...
$A] DAC_LDD Logi...

& DMA_LDD Logi...
&g DMATrans Logi...
=8| Ethernet L Logi...
€) Btint  High
& Extint_LDD Logi...
8H FLASH_LD Logi...
@ Freescale® Low

m

&' Init_ADC @ Add to project

4 Init_CMT Expand =il
1) Tnit_CRC :

i Init_DAC Collapse all

ii¥ Init_eDM & Refresh F5

A Init ENE] H  Delete Delete &

Jirlk T . FUAR

Figure 10. PEx Component insertion
4. Configure the I2C component.
a. For this application note, the I2C component should be configured as shown in the following figure.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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% Component Inspector - KB0_[2C &3
F'r-:uperties: Methods | Events |

Marme

Compeonent name

2C channel
a Interrupt service
Interrupt
Interrupt pricrity
4 Settings

Mode selection
a MASTER mode
4 Initialization
Address mode
Target slave address init
s SLAVE mode
4 Fins
4 SDA pin
A SDA pin
504 pin signal
4 SCL pin
A SCL pin
SCL pin signal
High drive select
Input Glitch filter
Internal frequency (multiplier facter)
Bits 0-2 of Frequency divider register
Bits 3-5 of Frequency divider register
SCL frequency
5DA Hold
SCL start Held
SCL stop Held
s Control acknowledge bit
> Low timeout
a Initialization
Enabled in init code
Auto initialization
s Event mask
P CPU dockf/configuration selection
Clock configuration 0

Value

Ka0_12C

2C0

Enabled

INT 120
redium pricrity

MASTER
Enabled

7-bit addressing
4C
Disabled

Example driver integration

Basi

Details

20

INT_I2C0
8

PTD9/I2C0_SDA/UARTS_TX/FB_ALT  PTDO/T2CO_SDA/UARTS_TX/FE_ALT

504

PTDE/M2C0_SCL/UARTS_RX/FB_A16  PTDE/M2C0_SCL/UARTS_RX/FB_Al6

SCL
Dizabled
]

48 MHz
000

110

75 kHz
1.354 us
6.625 us
6.687 us
Dizabled
Dizabled

yes
no

This component enabled

48 MHz

Clock conf. 0: 75 kHz

Clock conf. 0: 1.354 us
Clock conf, 0: 6625 us
Clock conf, 0: 6,687 us

This component is enabled

Figure 11. 12C component configuration
b. Also remember to enable the "Enable" and "Disable" methods for this component.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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£y Component Inspector - K60_12C £ Basic Advanced |

Properties | Methods . Events

Marme Value Details
Init generate code
Deinit don't generate code
Enable generate code
Dizable generate code
SetEventMask don't generate code
GetEventMask don't generate code
MasterSendBlock generate code
MasterGetBlockSentStatus don't generate code
MasterGetsentDataMum don't generate code
MasterReceiveBlock generate code
MasterGetBlockReceivedStatus don't generate code
MasterGetReceivedDataMum don't generate code

Figure 12. 12C component methods
5. Generate the code.
a. Now, generate the code by clicking the Generate Code button on the right-side corner of the Components
window, (as shown in the following figure), or choose Project > Generate Processor Expert Code.

©T Components - PExDrv &3 Sm
ErOj

4 = G.Eﬂ erator_Configurations

& RAM

# FLASH
. & 0Ss

4 [= Processors

Figure 13. Code generation button
6. Open the PEx_Drv_Int_Training workspace located at ...build\iar\PEx_Drv_Int_Training.
7. Select the PEx_Drv_Int_Training_k60_tower_project and select the Flash_256KB_PFLASH target.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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ﬁ PEx_Drv_Int_Training - IAR Embedded Work

File Edit ¥iew Project Tools Window

Dl S| R[>

Waorkspaco

»

[ FLASH_Z2EEKE_PFLASH

-

Files £
B [ PEx_Drv_Int_Trainin... +
—itl | cormmon
= [ cpu
—i=l ] drivers
—E (Jadcl b
& [(J enet
A (3 Iptmr
Carrnicy
M pmc
[ 3=
[ Tuar

O [Qwdaog
— T 1A
—= (1 platfarms
L— [&) kBO_tower.h
—= [ project

isr.h
FEx_Dire_Int_Traini...

—F [ Dt

43,

I FPE= Dre Int Training kB0 tower

8. Add the generated code to the Project.
a. Right-click the drivers folder and choose Add > Add Group.

Figure 14. Project selection IAR IDE

Example driver integration
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I—————— e

| FLASH_256KB_PFLASH v
Files o By
E(FPEx Drv Int_Tr... v
[(Jcomman
[(dcpu
B M
714 Options...
Op
[ . Make
[ale Compile
Rebuild All
Clean
Stop Build
Add » Add Files...
— . Add.ﬁruup.....
Bename...
Wersion Control System k
Open Containing Folder...
File Properties...

Figure 15. Add group selection in IAR
b. Name the group appropriately.

i

Group name:

i2d}

Figure 16. Add group dialog box in IAR
c. Right-click the folder you just created and choose Add > Add Files.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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B 20
| FLASH_256KE_PFLASH
Files &z
B G PEx_Drv_Int_Training_kb... v
[Jcommon
(dcpu
—E= (O drivers
[(Jadclb
[Jenet
— ([l
[t QOptions...
COmc
) pm Make
([l rtc Compile
—Euar Repyild Al
[(Twed
CIIAR Elca
—E0plafol g0 B
Olprojeq :
(3 Outpu. Add _ Add Files...
. Add Group...
Eename...
Version Control System
Open Containing Folder...
File Properties...

Figure 17. Adding files in IAR
d. Point IAR to the driver files that were generated (K60_I2C.c and K60_I2C.h) located at ...build\iar
\PEx_Drv_Int_Training\PE\Generated_Code.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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-

& Add Files - i2c 5
@(1:}'| . % build » iar » PEx_Drv_Int Training » PEx » Generated_Code - |<Ff| | Search Generated_Code 0 |
Organize = Mew folder = - [0 @

T * Mame i Date modified Type Size
Bl Desktop L] Cpu.c 10/9/2012 4:54 PM CFile 13 KB
4. Downloads L] Cpu.h 10/9/2012 4:54 PM HFile 8KE
=l Recent Places || I9_Map.h 10/9/2012 3:50 PM H File 882 KB
'] K60_2C.c 10/12/201212:06 ...  CFile 42 KB|
=3 Libraries | || KB0_2C.h 10/10/2012 518 PM  H File 20 KB
@ Documents ) || PE_Const.h 10/9/2012 3:50 PM H File 3KB
J’i Music E || PE_Error.h 10/9/2012 3:50 PM HFile S5KB
Pictures ] PE_LDD.c 10/17/2012 236 PM  CFile 2KB
=1l Subversion ] PE_LDL.h 10/10/2012 512 PM  H File 133 KB
B Videos || PE_Types.h 10/10/2012 4:40 PM  H File 4 KB
|| Vectors.c 10/9/2012 4:54 PM CFile 16 KB
L] Computer
% Prirnary (C:) |

o= Removable Disk |
+ C5-SatellitePerso
| My Web Sites on -

B 2 items selected Date modified: 10/10/2012 5:18 PM - 10... Date created: 7/1/2013 10:36 AM
Size: 60.4 KB

File name: "K&0 I2C.h" K60 [2C.c" - ISm.lrce Files (*.c™.cpp;™.ec™.h™ v]

| Open | | Cancel |

Figure 18. Add Files dialog in IAR
e. Right-click the project folder and choose Add > Add Files.
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[ FLASH_28EKEB_PFLASH

Files

—E (] comman
—H [(J cpu

—H [ drivers
—E [J1AR

—H (1 platforms
—E (]
—# [ Qutput

B (FFEx_Drv_Int_Traini..

..Add =S

Options...

Make
Compile
Rebuild All

Clean

Stop Build

| Add Files...

Remove Add Group...

Rename...

Version Control System r

Open Containing Folder...
File Properties...

Set as Active

r

Figure 19. Adding files to the Project group in IAR
f. Point IAR to the generated code folder and select PE_LDD.c and PE_LDD.h.
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& Add Files - project
@’Q,ﬂ < build » iar » PEx_Drv_Int_Training » PEx » Generated_Code - | 3 | | Search Generated_Code 2 |
Organize MNew folder =~ 0 @

& Favorites i Marne : Date modified Type Size
PR Desktop L] Cpu.c 10/9/2012 4:54 PM C File 13 KB
& Downloads L] Cpu.h 10,9/2012 4:54 PM H File 8KB
15| Recent Places || 19_Map.h 10,/9/2012 3:50 PM H File 8B2 KB
|| K60 I2C.c 10/11/2012 3:09 PM  C File 42 KB
4 Libraries || K60 12C.h 10/10/2012 5:18 PM  HFile 20 KB
@ Documents A || PE_Const.h 10/9/2012 3:50 PM - HFile 3KE
J? Music - || PE_Error.h 10,9/2012 3:50 PM H File 5KE
) Pictures ([ PELDD.c 10/10/20125:36 PM  C File 4KB|
=1 Subversion | | PE LDD.h 10/10/2012 512 PM  H File 133 KB
B videos || PE_Types.h 10/10/2012 4:40 PM  HFile 4 KB
|| Vectors.c 10/9/2012 4:54 PM C File 16 KB
. Computer
& Primary (C:) 4

e Removable Disk i
4 C5-SatellitePerso
| My Web Sites on -

b 2 items selected Date modified: 10/10/2012 5:12 PM Date created: 10/12/2012 11:10 AM
Size: 135 KB

File name: "PE_LDD.R" "PE_LDD.c" - [Source Files (*.c™.cpp;™.cq™.h™ V]

| Open | | cancel |

Figure 20. Add files dialog in IAR - PE_LDD files
g. Repeat steps "e" and "f" to also add Events.c and Events.h, located at build\iar\PEx_Drv_Int_Training\PE
\Sources, to the sources folder.
9. Add the paths to the Preprocessor include paths.
a. Right-click the project and select Options.

Integrating a Processor Expert Driver (LDD) into a Non-Processor Expert Project, Rev 0, 08/2013
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ﬁ PEx_Drv_Int_Training - IAR Embedded Weorkbench IDE
File Edit View Project Tools Window Help

Nad@ S 4 B2Ro o

Workspace x
[ FLASH_256KE_PFLASH - ]
Files ino B
EfEIPEx_Drv_Int Traini..
—# [ commaon Options...
(Jcpu
—A (I drivers Make
—E[(1AR Compile
— [ platforms Rebuild Al
[ project -
(3 Qutput G
Stop Build
Add 3
Remove
Rename...
Version Control System r
Open Containing Feolder...
File Properties...
Set as Active

Figure 21. Opening project options in IAR
b. A dialog will open for node "PEx_Drv_Int_Training_k60_tower". In the dialog, select the Preprocessor tab from
the C/C++ Compiler Category and add the following paths (also shown in the figure below):
* $PROJ_DIR$\PE\Generated_Code
» $PROJ_DIR$\PE\Sources
* The PDD include folder of the PEx install directory. (If you chose the default location for the PEx install,
this location will be C:\Freescale\PExDrv v10.2\eclipse\ProcessorExpert\lib\Kinetis\pdd\inc).
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Options for node "PEx_Drv_Int_Training_kB0_tower" @
Category: [ Factory Settings ]
General Options [ bulti-file: Campilation
Digcard Uruzed Publics

Assembler
Qutput Converter | Language 2 I Code | Optimizations | Ohutput I List | Preprocessor || 4 | *
Custom Build ] '
Build Adtions [ [Hgnare standard include directories!
Linker Addtional include directories: jone per line)
Debugger SPROJ_DIRSY MM erc'platforms -
Simulator SPROJ_DIRS .M

Angel EPROJ_DIRSWPEd\Sources =
A SPROJ_DIRS\PEx\Generated_Code L4

SFreescale’ rv v 1.2 eclipse\Frocessorespert i netis'pdayi =

A CMF le"PExDrv w10.2'eclipse'P Expertlib*Kinetis pdd®

IAR. ROM-manitor Preinclude file:

IHet/TTAGIet E]
MHinkf1-Trace ]

11 Stellaris Defined symbols: (one per line)

Macraigor &R o [] Preprocessor output ta file

PE micro TWR_KBOMNS1Z Preserve comments

RDI N Generate Hine directives
STLINK

Third-Party Driver

TI XD5100

[ ] ][ Cancel ]

Figure 22. Preprocessor tab in the project options of an IAR project
c. Click OK.
10. Modify the driver file, K60_I2C.c.
* K60_I2C.c should not include IO_Map.h, but should include common.h. Replace #include "IO_Map.h" with
"#include "common.h"" as shown in this figure.

23
94 S* MODULE KéQ I2C. #/
a5
96 #include "Events.h"
a3 #include "Ke0_IZC.h"
98 #includes "PORT PDD.h"
a9 #include "IZC_FDD.h"
100 A% {Default RIOS Adapter)
1ol #include "common.h'
102

Figure 23. K60_I2C.c includes
11. Modify the driver header file, K60_I2C.h.

¢ K60_I2C.h should only include common.h and PE_LDD.h. Replace all of the file inclusions (#include "<file
name here>") as shown in this figure.
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12. Modity PE_LDD.c.

Example driver integration

93

94 [-] #ifndef _ Ko0_I2C_H
95 #define _ Fe0_I2C_H
96
97 A* MODULE 60 I2C. #/
98
99 A% Imclude shiared modules, which dre o
100 #include “common.h™

101
2 #* Include inherited components */
103 #include "PE_LDD.h"

104

A

Figure 24. K60_I2C.h includes

¢ Remove the "#include "CPU.h"" statement.
* Remove all functions except for the declaration LDD_TDeviceData *PE_LDD_DeviceDataList [1].

13. Modify PE_LDD.h.

* Replace all of the file inclusions (#include "<file name here>") with "#include "common.h"" as shown.

14. Modity Events.c.

21 |

22 /* MODULE FE LDD. */
23

24 #include "common.h™
25

26 /* Logical Device Driver APY wersion */
27 | #define PE LDD VERSION

Figure 25. PE_LDD.h includes

* Events.c should include common.h but not CPU.h. Replace #include "CPU.h" as shown in the following figure.

16
17
15
19
20
21
22

e

I
L

L : i

/* MODULE Evants #/

#include "common.h”
#include "Events.h"

A% User includes (#include below this lirne is n

Figure 26. Events.c includes

* Add the following lines immediately after the header file inclusions (where the user includes are allowed):
* extern volatile bool DataTransmittedFlg;
* extern volatile bool DataReceivedFlg;
* Add to the K60_I2C_OnMasterBlockSent function "DataTransmittedFlg = TRUE;" this semaphore is used by the
provided example application to signal that data has been transmitted to the accelerometer.
* Add to the K60_I2C_OnMasterBlockReceived function "DataReceivedFlg = TRUE;" this semaphore is used by
the provided example application to signal that data has been received from the accelerometer.

15. Modify Events.h.

* Events.h should only include PE_LDD.h. Replace all of the file inclusions (#include "<file name here>") as

shown in this figure.
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cxample driver integration

18 [] #iftndef _ Events_H
19 | #define _ Events H
20 S MODWLE Events #/
21

22 | #include "PE_LDD.R"
23

Figure 27. Events.h includes
16. Modify common.h.
* common.h should include PE_Error.h and PE_Types.h. PE_Error.h defines error codes used by LDD files that
have been generated. PE_Types.h defines the constants necessary for the LDD drivers to operate. Add these
includes at line 72 as shown.

Dummnnll|
a2 #warning "No toolchain specific header included™
63  #endif
64
65 ] s
13 # Include common utilities
&l [ */

68 #include "asszert.h™
69 #include "io.h™

70 #include "startup.h”
71 #include "stdlib.h™
72 #include "PE_Error.h"
73 #include "PE_Tvpes.h"

T4

75 [ #if (defined(IZR))

TG #include "intrinsics.h"
71  #endif

Figure 28. common.h includes
17. Modify isr.h to install the Processor Expert generated interrupt handler.
* isr.h should include common.h

b
7 & #ifndef _ ISR H

g #define ISE H 1

9

10 Finclude “common.h"”
11 /% Example #/

12 1 ~+

Figure 29. isr.h includes
 To install the interrupt vector, redefine the appropriate vector as shown (remember to declare the ISR function).

Z0

Z1 fundef YECTOR_040

22 fdefine VECTOR_040 K60 _I2C Interrupt
23

24 extern PE _ISR(Ke0 I2C Intecrupt):

A

LI

Figure 30. Example of installing an interrupt service routine
18. a. Remove the definition of "Other basic data types"
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Example driver integration

FE_Iype5h|
58 typedel unsigned char bool;
589  f#endif
a0 typedef unsigned char byte;
&6l typedefl unsigned short word;
62 typedef unsigned long dword;
63 typedef unsigned long long dlong;
LT ! typedef unsigned char TPE_Errlode:
65 [] #ifndef TPE Float
66 typedef float TPE Float:
67  #endif
68 [] #ifndef char t
&9 typedefl char char_ t;
70 r #endif
71
72 /* Other basic data types */
73 A/typedef signed char
T4 J/typedef signed short int
75 J/typedef signed long int
76
77 //typedef unsigned char uink?:
78 J/typedef uvnsigned short in uinktlé;:
79 J/typedef wvnsigned long int uinkt33;
20
21
82 f****#*******#*******#*******#*******#*******#*******#*****’f
a3 J* Uniform multiplatform 8-bits peripheral access macros */
84 f****#*******#*******#*******#*******#*******#*******#*****’f
a5

Figure 31. Removal of "Other basic data types" from PE_Types.h

b. Modify the "EnterCritical" and "ExitCritical" functions as shown in the following figure.
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vounclusion
FJL
a9z /% Disahle maskable interrupts */
93 fdefine _ DI({) \

94 do I\

a5 __set_FAULTMASK({0xOlul); \
96 ] while(0)

97

o
(=)

99 F* Bave status register and disshle interrupts */
100 #define EnterCritical{) \

101 asm(™CPSID i™}:

102
103
104 /% Restore status register */
105 #define ExitCritical() \

106 asm(™CPSIE i™}):

107

108

108 fdefine PE DEBUGHATLT () *

110 F*1lint -save -£b586 -e950 Disable MISRA rule (2.1,1.1) checking. #*/\
131 asm{"BEPT 255"}

112 F*1lint -restore Enable MISRA rule (5.1,1.1) checking. */

Figure 32. Modification of EnterCritical and ExitCritical functions in PE_Types.h

6 Conclusion

In this application note, a general procedure is outlined for integrating a single Processor Expert Driver into an existing non-
Processor Expert project. A specific example of such an integration is also discussed using the Freescale sample code. The
general procedure is as follows.

1. Create a Processor Expert project.

2. Configure the PEx project as your project will be setup (this is a good general practice but will be required if your
driver is a time-dependent module, such as a timer or communications module).

3. Generate the code.

4. Add the generated code to the project (typically you only need to add Events.c, Events.h, PE_LDD.c, PE_LDD.h,
<Component Name>.c, and <Component Name>.h) and the PDD files.

5. Modify the driver files that have been added (no files will need Cpu.h, PE_Types.h, IO_Map.h, or PE_Const.h. In
addition, all of the code should be removed from PE_LDD.c except for the LDD_DeviceData defintion. Also, several
standard type definitions, EnterCritical, ExitCritical, and PE_ISR definitions must be added to a common included file,
such as the part specific header file or arm_cm4.h.).

It must be noted that each application may use drivers in a different manner and different drivers may require different
definitions and other code located in other Processor Expert files. Thus, each driver integration may be slightly different, but
the general procedure will remain the same.

7 References

KINETIS512_SC: Kinetis family example projects, available at freescale.com

KINETIS512_SC_V2: Kinetis I00MHz Rev 2 Example Projects, available at freescale.com

* Kinetis resources are available at www.freescale.com/Kinetis

* Processor Expert resources are available at www.freescale.com/ProcessExpert or at www.freescale.com/infocenter.
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